【回線】NEC+CiscoルータでHomeNOCに接続する

概要

機会があり、HomeNOCさんに接続させて頂きました。備忘録です。

こちらの方法は上手く行きました。

ちなみに、Ciscoのルータ1台でやろうとして上手く行かなかった(【回線】CiscoルータでHomeNOCに接続する)ので、NECのルータを買い足しました。


手順

① HomeNOCさんのホームページでやること
② NTTさんにお願いすること
③ NEC+Ciscoのルータでやること
の3種類があります。


① HomeNOCホームページでやること

まずはホームページをよく読みます。

次に、ダッシュボードにアクセスし、必要事項を記入。

IPv4アドレスのサブネットマスクですが、サーバ用途なら/30を選択すると良いでしょう。1つはゲートウェイ、1つはブロードキャストのため、2つがグローバルIPとして使えます。どれを選べば良いか困ったらSlackなりメールなりで質問してみましょう(もちろん自分で勉強している前提ですが)。

接続方式及び回線種別はL3接続(BGP)、トンネル(EtherIP)を選択します。

ちなみに「接続情報の追加」で以下のように400エラーが出るのはシステムの不具合とのことです。同じ事象に遭遇した人はGitHubで同種の不具合が報告されていないかSlackで問題が周知されていないか確認してから、GitHubでIssueを立てて運営委員さんにメール(support@homenoc.ad.jp)で問い合わせてください。

※不具合に至った背景(ここにはどれくらい勉強しているかの指標も含まれます)と答えてほしいことを明確にしてから問い合わせましょう。

[400] error: invalid ipv4 route template
OK

補足:接続方式および回線種別について

HomeNOCさんのホームページを見ると、Static Routing/BGP接続、GRE/IPIPトンネルなどという用語が並んでいるので戸惑ってしまいますが、少し前提知識が必要なので補足です。

【回線】Static Routing/BGP接続、GRE/IPIPトンネルの違い


② NTTにお願いすること

webでの申請が最終段階(接続情報の追加)に進み、IPv6アドレスを記入する段になったらフレッツ光を引きます。

無償のIPv6オプションは必ず付けてもらってください。ちなみに小型ONUも無償オプションです(こちらは変更してもしなくても構いません。「対応したルータを持っていて、どうしても使いたい」と伝えれば融通してもらえます)。

私の家では「フレッツ光ネクスト マンション・ギガラインタイプ」を引きました。

図2.フレッツ光ネクスト マンション・ギガラインタイプ

マンションに導入されていたインターネット環境がVDSL方式だったため、光配線方式に変更するところから手続しました。2022年1月末に手続を始めて開通したのは4月15日です。回線工事には延べ3ヶ月を要し、内訳はVDSL→光配線の切替えにおおよそ2ヶ月、スプリッタ→部屋への工事に1ヶ月かかりました。



③NEC+Ciscoのルータでやること

ルータはNEC IX2105と、Cisco 891FJ-K9を1台買いました。あと小型ONUのSFP規格をRJ-45に変換するために10Gtek 光メディアコンバーターを買いました。

まずは小型ONUを10Gtekの光メディアコンバーターのSFPポートに挿します。図3のようにしました。NEC IX2105の GigaEthernet 0 にWAN回線が来るようにして、さらにNEC IX2105の GigaEthernet 1.1 とCisco 891FJ-K9の GigabitEthernet 8 をつなぎます。

左側面が光る本小型ONUは、モデル名にMと入っているので三菱製ということが分かります。

小型ONUを挿してランプが点いたら、コンソールケーブルを挿してルータのセットアップを行います。

※本体を初期化せず立ち上げたらユーザ名がkashiwazaki_kariwa_xxx でした。ルータは初期化してから使いましょう。


・EtherIPの設定

まずはNEC IX2105の設定です。およその操作はCiscoルータと同じです。

■NGNのSNTPを使って時刻同期する
ntp server 2001:a7ff:102::c priority 3
ntp server 2001:a7ff:102::b priority 2
ntp server 2001:a7ff:102::a

■トンネルパフォーマンスの効率化
ip ufs-cache enable
ipv6 ufs-cache enable

■NGNピア先のみ疎通を許可する
ipv6 access-list ngn permit icmp src any dest any
ipv6 access-list ngn permit ip src 2405:****:****:****::/64 dest any

■ブリッジの有効化
bridge irb enable

■NGN内DNSの参照を有効化
ipv6 name-server 2001:a7ff:5f01::a
ipv6 name-server 2001:a7ff:5f01:1::a
dns cache enable

■NGNインタフェースの設定。
interface GigaEthernet0.0
  no ip address
  ip filter ngn 10 in
  ipv6 enable
  ipv6 interface-identifier 00:00:00:00:00:00:00:02
  ipv6 address autoconfig receive-default
  no shutdown

■Ether-IPでブリッジとして繋がるインタフェースはこちら
interface GigaEthernet1.0
  no ip address
  bridge-group 1
  no shutdown

■EtherIP用トンネル
interface Tunnel0.0
  description Homenoc
  tunnel mode ether-ip ipv6
  tunnel destination 2405:***:***:****::****
  tunnel source 240b:****:***:****::2
  no ip address
  bridge-group 1
  bridge ip tcp adjust-mss 1404
  bridge ipv6 tcp adjust-mss 1384
  no shutdown

NGN内の自分のIPアドレスは次のコマンドで確認できます。

Router# conf t
Router(config)# show ipv6 add
Router(config)# exit
図4.自分のIPv6アドレスの確認

一応、念の為ですが、NGN内のトンネル対向(私の場合は、2405:***:***:****::****)にpingが疎通するか確認してください。ダッシュボードに書かれてる値がいつも正しいとは限らないです。

図5.トンネル対向へのping疎通

参考:
BLUECORE.NET|[Network] Home NOC Operators Groupに接続をした。


・Ciscoルータの設定

まずBGPの設定をします。

Router# configure terminal
Router(config)# router bgp 65041
Router(config-router)# neighbor 103.247.181.166 remote-as 59105
Router(config-router)# address-family ipv4
Router(config-router-af)# neighbor 103.247.181.166 activate
Router(config-router-af)# network 103.202.216.68 mask 255.255.255.252
Router(config-router-af)# end

↓ コマンドをコピペで流し込みたい人用 ↓
conf t
router bgp 65041
neighbor 103.247.181.166 remote-as 59105
address-family ipv4
neighbor 103.247.181.166 activate
network 103.202.216.68 mask 255.255.255.252
end

プライベートAS番号はダッシュボードの左上にちょろっと書いてある64512~65535の番号です。

続いて、インターフェイスの設定をします。

Router# conf t
Router(config)# int gi 8
Router(config-if)# ip address 103.247.181.167 255.255.255.254

↓ コピペ用 ↓
conf t
int gi 8
ip address 103.247.181.167 255.255.255.254

この時点で対向機器へのping疎通を確認してください。

図6.対向機器への疎通確認

図6の赤線のエラー(Warning: use /31 mask on non point-to-point interface cautiously)は無視して構いません。

続いてLANポート(GigabitEthernet0-7)にIPアドレスを割り当てます。


Router(config-if)# int vlan 1
Router(config-if)# ip address 103.202.216.69 255.255.255.252

↓ コピペ用 ↓
int vlan 1
ip address 103.202.216.69 255.255.255.252

安心感を得たいのでここでもping疎通を確認します(図7)。

図7.ping疎通の確認

ここまで来ればほとんど設定は終わりです。お疲れ様でした。

————-

一応、ここからは、DNSやNATなどインターネットを使うための追加設定をします。まずはDNSの設定です。

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# ip name-server 8.8.8.8 8.8.4.4
Router(config)# ip name-server 2404:1A8:7F01:A::3 2404:1A8:7F01:B::3
Router(config)# ip name-server 2001:4860:4860::8888 2001:4860:4860::8844

続いて自分自身をDNSサーバとして使えるようにして、NTPサーバの設定を行います。

Router(config)# ip dns server
Router(config)# ntp server ntp.nict.jp
Router(config)# ntp server pool.ntp.org
Router(config)# exit


以上で、設定は終了です。LANポート(GigabitEthernet0-7)のどこかにPCをつないで、
・IPアドレス: 103.202.216.70
・サブネットマスク: 255.255.255.252
・デフォルトゲートウェイ: 103.202.216.69

・DNSサーバ(プライマリ): 103.202.216.69
・DNSサーバ(セカンダリ): 8.8.8.8 or なし
などと設定するとインターネットに繋がるはずです。

——————————————

この後は、運用するネットワークのレベルに応じて
DHCPやNATの設定 ※専用のルータを1台用意するのが手っ取り早いです。
 → このページ(【Cisco】ルータの設定 [Softbank Air] )
・ssh / Telnetの設定(リモートでPCからコンソールを開けるようにする)
 → こちらのサイト(ネットワーク入門サイト)
・セキュリティ設定(不要な機能やアクセスを制限する)
 → こちらのサイト(ネットワークエンジニアとして)
などを行います。

——————————————


補足

1. NAT/PATでルータを使いたい

一番最後のPCをルータに変えれば、複数台のPCでインターネットを使うことが出来ます(いわゆるNAT/PATです)。参考までに、そうした使い方をする場合のルータのconfig例を書いておきます。

ルータはCisco 2901/K9 V4です。Gi0/0にWAN側のLANケーブルを挿しています。

R1#show run
Building configuration...

Current configuration : 2890 bytes
!
! Last configuration change at 20:59:45 JST Sun May 8 2022
! NVRAM config last updated at 20:59:45 JST Sun May 8 2022
! NVRAM config last updated at 20:59:45 JST Sun May 8 2022
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone JST 9 0
!
ip cef
!
!
!
ip dhcp excluded-address 192.168.101.250 192.168.101.254
ip dhcp excluded-address 192.168.101.1 192.168.101.2
!
ip dhcp pool sales
 network 192.168.101.0 255.255.255.0
 default-router 192.168.101.1
 dns-server 8.8.8.8 8.8.4.4
 lease 0 2
!
ip dhcp pool server4
 host 192.168.101.4 255.255.255.0
 client-identifier 0152.a74f.5e33.9b
 client-name server4
 default-router 192.168.101.1
 dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool server3
 host 192.168.101.3 255.255.255.0
 client-identifier 01a0.7817.81fd.94
 client-name server3
 default-router 192.168.101.1
 dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool server5
 host 192.168.101.5 255.255.255.0
 client-identifier 0118.c2bf.b066.ef
 client-name server5
 default-router 192.168.101.1
 dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool server6
 host 192.168.101.6 255.255.255.0
 client-identifier 0134.97f6.a0bd.2b
 client-name server6
 default-router 192.168.101.1
 dns-server 8.8.8.8 8.8.4.4
!
!
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip name-server 103.202.216.69
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2901/K9 sn FGL191023F1
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
!
interface GigabitEthernet0/0
 ip address 103.202.216.70 255.255.255.252
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 no ip address
!
interface GigabitEthernet0/0/1
 no ip address
!
interface GigabitEthernet0/0/2
 no ip address
!
interface GigabitEthernet0/0/3
 no ip address
!
interface GigabitEthernet0/1/0
 no ip address
!
interface GigabitEthernet0/1/1
 no ip address
!
interface GigabitEthernet0/1/2
 no ip address
!
interface GigabitEthernet0/1/3
 no ip address
!
interface Vlan1
 ip address 192.168.101.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 103.202.216.69
!
access-list 1 permit 192.168.101.0 0.0.0.255
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 30 0
 logging synchronous
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
ntp server pool.ntp.org
ntp server ntp.nict.jp
!
end

必要であればDHCPの余計な部分を省いたconfigを教えますので言ってください。


2. 速度はどれくらい出るの?

何の参考にもなりませんが、速度を測った結果を載せます(図8)。

図8.速度計測(1回目)

2Gbps・・・?壊れてますね。再度計測した結果は図9です。

図9.速度計測(2回目)

昼間ということもありますが、下り570Mbps, 上り310Mbps、と中々の速度です。

普通のプロバイダだと、大抵は上りの方が速いですが、HomeNOCは下りの方が速いようです。サーバを公開しているユーザが多いからでしょう。

3. 自分もやってみたい

ぜひ挑戦してみたら良いと思います。不具合はGitHubへ、不明点はSlackでユーザコミュニティの知恵を貸してもらいましょう。それでも解決しない場合は運営さんにメールしてみましょう。いずれの場合もどのような操作をした結果、どういう不具合が出ていて、何を教えてほしいのかを明確にして質問してください。聞いた後はお礼と結果報告を忘れずに

私の知識的に答えられる範囲であれば、お答えしますので、疑問点や感想はコメントで知らせてもらえればと思います。

当ブログもHomeNOCさんも非営利で、お金は入ってきません。教えてもらえる/サービスを提供してもらえるのは「たまたま」です。「教えてもらって当然」ではありません。教えてもらったら、お礼と(次に読む人が困るので)結果報告を忘れずに

作成者: rarafy

2013年くらいからUnityを触っているかもしれません。 特に書くこともありませんが、趣味は部屋の掃除です。

5件のコメント

  1. コメント失礼します。
    最近HomeNOCの存在を知ったのですが、HomeNOCとはどういったものなのでしょうか?

    1. KOBAYASHIさん、コメントありがとうございます。

      HomeNOCは平たく言うと、自分たちでプロバイダをやっている団体です。ネットワークに興味のあるエンジニアが集まり、資金を出し合ってAS番号を取得し、プロバイダと同じようなことをしています。

      Slackでネットワークに関する質問だったり、コアな技術について話し合ったりもしているようです。

      1. とても分かりやすい説明ありがとうございます。
        ということは、HomeNOCに加入するとHomeNOCの回線(ISP)が使えるようになる+(ここの認識が間違っているかもしれません)自分達もAS番号やグローバルIPアドレスを取得することができるということでしょうか?
        少し気になったのですが、サーバー公開等の用途であれば普通のISPでも問題ないと思うのですが何かHomeNOCを利用するメリットはあるのでしょうか?
        また既に光回線を自宅に引いている状態でISPをHomeNOCにしたい場合はどうなるのでしょうか?
        質問続きになってしまい申し訳ございませんが、よろしくお願いいたします。

        1. 混乱しやすい部分ではあるのですが、順を追って説明します。

          まず、NTTは光ファイバーを引いてくれる会社です。電柱と電線・光ファイバーを日本中に張り巡らせています。

          次に、商用プロバイダはNTT東日本/西日本と契約し、NGN内でユーザーから信号を受け取ります。プロバイダ同士は設備を出し合って互いに接続しています。大抵はダークファイバ、専用線、自前でケーブル引く等の方法が使われているようです。

          最後に、プロバイダには1個のAS番号と複数のIPアドレスの塊(256個単位)がJPNICから配布されています。前者は「ISP(自律システム)」として、後者は「IPアドレス管理指定事業者契約」として申請を行っているものです。

          さて、ご質問への回答ですが、HomeNOCもプロバイダの一種です。一般社団法人です。
          コミュニティに参加すればネットワークに関する質問に対応してもらえます。実験用ネットワークに参加すれば、インターネットに接続することが出来ます。希望すれば固定IPアドレスも割当を受けることが出来ます。

          メリットは、ネットワークの勉強が出来ることでしょうか。普通のISPでは通常、PPPoE・IPoEという接続方式を取りますが、HomeNOCの場合は、EtherIPトンネル・GRE/IPIPトンネル・物理回線といった接続方式が認められます。BGPの知識も付きます。ネットワークの勉強になるはずですよ。また、固定IPアドレスの割当を安価に多く受けられます(ただしJPNICからの要請により、1年以内に使用率100%を満たす必要があります。数値違ったらすみません)。

          商用サーバーの公開等の目的であれば、通常のISPをご利用ください。通信品質はHomeNOCが提供するトンネルよりも、通常のISPが提供するIPoE接続の方が優れています。使用率についてもとやかく言われません。

          1. 補足回答になりますが、固定IPアドレスは申請すれば払出しを受けることが出来ますが、AS番号の割当は受けられません。

            既に光回線を引いている場合、プロバイダのみを変更することになるかと思います(大抵は事務手続きだけで済みます)。

            例えば、ドコモ光をお使いの場合、NTT東日本の光ファイバーを使い続け、プロバイダだけをドコモ光→HomeNOCに変更することになります。

            ただし、KDDI(関東圏)は自前で光ファイバー網を構築していたり、SonyはNTTのダークファイバーを使ってサービスを提供していたりと、ご家庭の光ファイバーの持ち主によっては東西フレッツ光の家庭用/マンションタイプを引き直して頂くことになるかと思います。

            前者のケースでも、新たに光ファイバーを引き直さなければならないこともあります。その辺は個別の契約に準じます(回線名と契約内容が分からないと具体的な回答は出来ません)。

            NTT東日本の場合は、マンションタイプの引込み本数の制限がありませんが、西日本の場合は一戸あたり一本までというルールもあったはずです。

コメントする

メールアドレスが公開されることはありません。 が付いている欄は必須項目です