【Cisco】リンクアグリゲーションを設定する

概要

2つ以上の物理ポートを束ねることで一本の通信線とみなす技術があります。リンクアグリゲーションと呼ばれています。

メリットは以下です。
・耐障害性が向上する
・通信速度が速くなる場合もある

☆本記事に書かれている内容ーーーー
 ・設定方法(Cisco間)
 ・Windowsの場合
--------------ーーー


構成

Ciscoスイッチで使えるリンクアグリゲーションには、「静的」「LACP」「PAgP」の3種類があります。

静的 LACPに対応していない場合に使われる On  
LACP LinkAggregation Control Protocol
IEEE802.3ad
Active 積極的にLACPを送信して論理リンクを作る。
Passive 自分でLACPを送信せず受け取ったら論理リンクを作る
PAgP Port Aggregation Protocol
シスコの独自プロトコル
使わない
Desirable 積極的にPAgPを送信して論理リンクを作る。
Auto 自分でPAgPを送信せず受け取ったら論理リンクを作る

 



手順

ちょうどSFPポートが付いた機器がありますから、これを使います。ポート番号は49番と50番にします。
図1の黄色い線同士でリンクアグリゲーションを組むことにしましょう。

図1.リンクアグリゲーション(黄色い線同士で組む)

①最新の機器の場合

次のコマンドを流し込みます。

Switch# configure terminal
Switch(config)# interface range Gi 0/49 , Gi 0/50
Switch(config-if-range)# switchport trunk encapsulation dot1q
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# channel-group 1 mode on

Switch(config-if-range)# no shutdown

反対側も同じように設定してください。

②古い機器の場合

Cisco Catalyst2960等の古い機械では、dot1qが使えません
次のコマンドを流し込みます。

Switch# configure terminal
Switch(config)# interface range Gi 0/49 , Gi 0/50
Switch(config-if-range)# channel-group 1 mode on

Switch(config-if-range)# no shutdown

反対側の機器も同様に設定します。


確認

設定後はshow etherchannel summaryで確認できます。

Switch# show etherchannel summary
Flags: D - down        P - bundled in port-channel
       I - stand-alone s - suspended
       H - Hot-standby (LACP only)
       R - Layer3      S - Layer2
       U - in use      f - failed to allocate aggregator
       M - not in use, minimum links not met
       u - unsuitable for bundling
       w - waiting to be aggregated
       d - default port
 
Number of channel-groups in use: 1
Number of aggregators:           1
 
Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------
1      Po1(SU)       LACP        Gi0/49(P) Gi0/50(P)

太字部分はGi0/49とGi0/50がイーサチャネル(=リンクアグリゲーション)に組み込まれ、port-channel 1が使えることを示しています。


元に戻す

チャネルグループを削除する場合は

Switch# config terminal
Switch(config)# interface range Gi 0/49-50
Switch(config-if-range)# shutdown
Switch(config-if-range)# exit
Switch(config)# no interface port-channel 1

とします。


補足

・Windowsとリンクアグリゲーションしたい

Windows側は、このサイトの手順でセットアップします(図2)。

スイッチ側はモードに関係なくchannel-group 1 mode onでセットアップします。

図2.実際にチーミング運用している様子

・Windows Serverの場合

サーバーマネージャーの「ローカルサーバ>NICチーミング」の部分から設定できます。

図3.NICチーミングの設定

「無効(有効)」と書かれた部分を押すと設定可能で、図4のように3か所設定します。なぜかLACPだとうまく動かないので、静的チーミングを選択します。

図4.チームのプロパティ


参考資料

リンクアグリゲーションの設定 – Catalyst(ネットワーク入門サイト)
L2 EtherChannel Configuration(ネットワークエンジニアとして)
リンクアグリゲーションで複数の物理回線を束ねる(LAG,LACP)(現場で必要なネットワーク技術入門)
チャネルグループの削除(ALAXALA)

作成者: rarafy

2013年くらいからUnityを触っているかもしれません。 特に書くこともありませんが、趣味は部屋の掃除です。

2件のコメント

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です